From gc-linux

Jump to: navigation, search

Troubles with DVDs.

Should this go on the main and/or Wii:DVD pages Disk Compatability Hints


I tried with 10 different dvd-discs, but no luck. I'm running the latest kernel from bootmii and I've updated my debian from etch to lenny and I'm currently running the system from USB-stick.

My drive works ok with wii games and with dvdx + mplayer, it has been making some loud noise for about year now, but it still works like a charm!

This is what I get when trying with rnd wii game disc

# mount -r -t iso9660 /dev/rvl-di /mnt/dvd/
# mount: No medium found
# dmesg | tail
# [ 1445.073779] rvl-di: drive reset
# [ 1453.268359] rvl-di: command READPHYSINFO failed
# [ 1453.268376] rvl-di: drive_status=05053100, [disk id not read, unkown]
# [ 1433.268405] rvl-di: media NOT ready

This is what I get when trying with rnd CD-R DVD-R disc

# mount -r -t iso9660 /dev/rvl-di /mnt/dvd/
# mount: No medium found
# dmesg | tail
# [ 1651.790029] rvl-di: disk inserted!
# [ 1669.057502] rvl-di: drive reset
# [ 1676.293859] rvl-di: command READPHYSINFO failed
# [ 1676.293875] rvl-di: drive_status=05053100, [disk id not read, unkown]
# [ 1676.293905] rvl-di: media NOT ready

This is also a famous error occurring with some of my self baked DVDs

  1. mount -r -t iso9660 /dev/rvl-di /mnt/dvd/
# mount: No medium found
# dmesg | tail
# [ lots of numbers] rvl-di: disk inserted!
# [ lots of numbers] rvl-di: drive reset
# [ lots of numbers] rvl-di: command READPHYSINFO failed
# [ lots of numbers] rvl-di: drive_status=03023a00, [no disk, medium not present]
# [ lots of numbers] rvl-di: media NOT ready

--Wiibrewfan4 18:22, 7 Dec 2009 (UTC)

The driver does _NOT_ read DVD games on purpose.
The DVD unit does _NOT_ read CDs.
Regarding the "self-baked" DVD media, are you using a chipped Wii? If it is not chipped and it works with DVDX then it should work with rvl-di.
--isobel 23:56, 7 Dec 2009 (UTC)
Chips away. No I'm a softmod user and fan, so i wii is not chipped. And by writing "self-baked" i was referring to normal DVD-R disc with one mkv-file in it, that i burnt yesterday. It worked fine on both of my computers. I will test DVD-R discs from other manufacturers today, so stay tuned. What I like the most in the latest kernel, is that my wireless ortek keyboards integrated mouse touchpad works now when the receiver is plugged in my USB-hub. So hats off! --Wiibrewfan4 08:59, 8 Dec 2009 (UTC)
Ah, there was a typo in "This is what I get when trying with rnd CD-R disc", I meant DVD-R disc. Sorry! --Wiibrewfan4 11:17, 8 Dec 2009 (UTC)
Okay. Your kernel works just fine. The disc drive of my wii is slowly dying. I applied some preassure to disc drive by pushing the case from certain points and the test DVD (The Octacon, Gotta love Chuck Norris) Worked! I think it's soon time to open my Wii or the disc drive will be dead. --Wiibrewfan4 20:00, 8 Dec 2009 (UTC)
Before the attempt to fix my optical wii disc drive i must state, that I'm still puzzled why all the wii games are working with my drive but every single dvd fails with DVDx or MikeP5s rvl-di.--Wiibrewfan4 15:55, 9 Dec 2009 (UTC)

DVD Drive Compatibility

I'm guessing this won't work with the newer drive firmware that DVDx does not work with? RobotMenace 16:47, 8 Dec 2009 (UTC)
There is a new drive PCB with a chip that doesn't accept normal DVD read commands. This driver won't work on those drive units. They are currently not blacklisted as I don't have the reported date of such drives.
Can you please post the output of a "dmesg | grep rvl-di" if you have such a drive? Thanks.
--isobel 16:58, 8 Dec 2009 (UTC)
I'm really sorry, I've got a very old Wii here. Hopefully someone with such a drive will see that and post the output. RobotMenace 18:37, 8 Dec 2009 (UTC)

# mount: No medium found

I always received this error when trying to mount a dvd. If I booted up with out a disc in the drive, but if I had a dvd inserted when I booted up. I was able to mount and unmount even eject the disk and insert a new one that mounted fine.--Linus 06:39, 9 Dec 2009 (UTC)

Personal tools