Talk:WL:whiite-linux

From gc-linux

Jump to: navigation, search

Contents

Great Job!

Thank you very very much. This is a great news for all Wii owners. It deserved bigger media coverage. Xyrion 05:29, 9 Jul 2008 (PDT)

Unsupported USB audio devices?

You say that "USB devices using isochronous transfers" are not supported. Is that caused by some Wii hardware incompatibility or is it just a temporary state for this Whiite release? I would really like to use my USB DAC with Wii one day. Could it be possible? I've read somewhere that it uses the standard snd_usb_audio kernel module. Xyrion 05:29, 9 Jul 2008 (PDT)

The kernel supports isochronous transfers now when booting via BootMii. --isobel 15:08, 15 Dec 2009 (UTC)

Gamecube keyboard compatibility

Is it possible to use a PS/2 or USB keyboard (via a converter) through the Gamecube controller port? I'm interested in trying to get this running on a Gamecube...

Nevermind I think I just answered my own question by looking at the gc-linux source. Looks like it does support PS/2 / USB keyboard via the Gamecube controller serial ports + adapter Jeema 00:33, 7 Aug 2008 (EDT)

Error?

Under "Installation of the Kernel Image", where it says "unmount the fat16 filesystem", the command shown is "$ sudo mount /dev/rvlsda1". Shouldn't this be "$ sudo umount /dev/rvlsda1"?

Yup, thanks, fixed. --isobel 14:06, 26 Aug 2008 (PDT)

SDL Help

I've been trying to get a SDL game to run on the Wii and cannot get past the following error when executing the game: "Couldn't initialize SDL's Audio/Video: No available video device" I compiled and installed the libsdl from the Kobo Deluxe source since it's version 1.2.11 which is what I need to run my game. The only way I could think of getting it to work was to try "export SDL_VIDEODRIVER=gc" but that didn't help at all. I've searched all over for a solution and have found none so far. Does anyone have any suggestions as to how to fix this? -- Akira8 8:24AM, 27 Aug 2008 (CDT)


Try executing the following before running your game:

$ export SDL_NOMOUSE=1

--isobel 09:27, 27 Aug 2008 (PDT)

Didn't work but that was a good idea. I'm guessing now that it doesn't run at fullscreen automatically so I need to change some source code around so it does. I'm going to talk with one of the games programmers to find a solution to that and I'll update you with what happens. Thanks Isobel.

--Akira8 17:31, 28 Aug 2008 (CDT)

Found out something incredibly stupid, the GC driver wasn't even installed when I compiled SDL because I didn't have libdirectfb-dev. So I've fixed that now but I'm now getting the following error from the driver "Cannot get console hardware info". I'm guessing it doesn't even know it's running on a Wii somehow?

--Akira8 23:40, 13 Sep 2008 (CDT)

Please, have a look at the kobodl sources to see how to build SDL. You don't need DirectFB.

--isobel 10:37, 14 Sep 2008 (PDT)

DVD drive device, with wiikey?

From what I can understand whiite doesn't support the DVD drive because it is locked out to things using unsigned code. What about with a modchip? Wouldn't that get around the lockout? I don't know so I am asking as I would really like access to the Wiis internal drive.

There's no need to use a modchip to access the dvd drive from gc-linux. But we haven't (for no technical reasons) written a driver yet. --isobel 16:36, 24 Nov 2008 (UTC)
A driver for the DVD unit is now available. --isobel 15:06, 15 Dec 2009 (UTC)

Changing Keyboard Layout

I have a small problem: my keyboard is a USA-USA keyboard, and I can't input the commands to change Whiite Linux's preferences because of the differences. Can I fix this problem by changing a file in Ubuntu? I have Ubuntu on a live disc, so I (technically) should be able to do this, right? But how?

You can mount the 2nd partition of your SD card (where the whiite filesystem is stored) in your Ubuntu box, for example at /media/whiite, then remove the soft link /media/whiite/etc/console/boottime.kmap.gz and recreate it pointing to your actual kmap. For example, you can do it using the following command: sudo ln -f -s /usr/share/keymaps/i386/qwerty/us.kmap.gz /media/whiite/etc/console/boottime.kmap.gz --isobel 21:13, 10 Jul 2009 (UTC)

WiFi fails

I set the internal WLAN card with whiite-ez-wifi-config. After selecting "bring up the connection" a black screen flashes and it says that the connection could not be established. wlan0 is not even detected. Any ideas? Thanks --MadCatMk2 12:06, 15 Dec 2009 (UTC)

WiFi only works when booting with BootMii (either direct boot or through BootMii menu). --isobel 15:04, 15 Dec 2009 (UTC)
Thanks Isobel. Someone made it clear for me on #wiilinux. Also mentioned "this is soo isobel" for some reason. --MadCatMk2 22:55, 15 Dec 2009 (UTC)
I also have a problem with Wi-Fi. BootMii is installed in boot2. I'm using the latest whiite debian/lenny realease with MIKEp5 launched via /bootmii/ppcboot.elf. I've used whiite-ez-wifi-config to setup my SSID and my WEP-binary key.
My Wii can never establish a connection with my router (DLINK DSL-G604T) - it timesout when trying to associate. It did once connect, which I promptly typed apt-get update, then apt-get links - but the connection dropped at 60% completion. Never had a subsequent connection.
I've tried moving the router adjacent the Wii - no luck. I've tried disabling WEP completely (open access point) - no luck either (I've rechecked my SSID and WEP-key in /etc/network/interfaces many times). I've spent hours trying to get this thing to work - sooo frustrating.
Using "iwlist wlan0 scan" detects the router, it's SSID and mac address.
My Wii can still access the net through regular system menu + opera browser etc
My problem looks identical to: http://rt2x00.serialmonkey.com/phpBB/viewtopic.php?f=5&t=5231
Any ideas? Sge 09:11, 1 Feb 2010 (UTC)
Are you using WEP? Triple-check /etc/network/interfaces for the correct key format. Also make sure "iwconfig wlan0" shows your proper configuration (ESSID and key). --isobel 18:10, 1 Feb 2010 (UTC)
I managed to get it working (barely). Since it timesout while authenticating and/or associating, I keep "ifdown wlan0" then "ifup wlan0" until it connects properly and gives me an IP. It is much slower than before (<1kb/s - 20kb/s), but atleast it's working.
I reverted back to an old setup (etch+MIKEp3/4) - didn't do much good but since I know how to establish an (unreliable) connection, it's not too bad. It seems two other people have had similar problems in recent days with Wii-Linux's Wi-Fi (http://gbatemp.net/index.php?showtopic=177262&st=150&gopid=2576405&#entry2576405).
I seriously can't remember it being this slow and unreliable before I formated and updated to the kernel version 2.6.32 with MIKEp5. But oddly, reinstalling to (what I remember) my old setup was like didn't help. Sge 03:01, 4 Feb 2010 (UTC)
Personal tools